[主機板] 華碩主機板裝機後開機無顯,通過連接蜂鳴器的辨別方式

https://www.asus.com/tw/support/FAQ/1029959/

1. 電源指示燈亮起,蜂鳴器回應一短聲,但沒有畫面顯示

蜂鳴器回應一短聲為正常開機,請確認螢幕與主機有正確連接且螢幕正常運作。

2. 電源指示燈亮起,蜂鳴器沒有回應

請確認您的CPU與記憶體安裝正常且接點部分沒有氧化,若存在著氧化問題,請先嘗試用橡皮擦擦拭氧化的部位,若還是不能正常開機,則以市售的接點清潔劑清理後重新安裝。

3. 蜂鳴器回應一長聲二短聲

記憶體的偵測異常,請確認記憶體有正確安裝在主機板上。

記憶體的說明相關請參考主機板使用手冊。

4. 蜂鳴器回應一長聲三短聲

顯示器偵測VGA異常,若VGA需要額外供電請確保電源有提供足夠的瓦數。

5. 蜂鳴器回應一長聲四短聲

CPU風扇轉速異常或CPU溫度異常或CPU電壓異常

請確認您的CPU或CPU風扇是否安裝正確。如果依舊異常,請嘗試清除CMOS或進BIOS load default

發表於 未分類 | 發表迴響

Python:字典練習

利用字典輸入 果菜市場品項顯示價格
輸入-1 跳出程式
輸入沒有水果的 顯示無品項

dict1 ={"香蕉":10,"芭樂":20,"蘋果":30,"eee":50}
while True:
name=input("請輸入你要買的水果: ")
buy=(dict1.get(name))
#print("test-你買的: %s 價格為= %d" % (name,buy))
if(name=="-1″):
break
elif(buy==None):
print("這品項沒賣")
else:
print("你買的: %s 價格為= %d" % (name,buy))

發表於 未分類 | 發表迴響

多台ubuntu vm 拿取相同ip

Clone出來 Ubuntu VM雖然MAC addr不同, 但卻會同時向DHCP要求相同的IP; /etc/machine-id 都相同

sudo truncate -s 0 /etc/machine-id && \
sudo rm /var/lib/dbus/machine-id && \
sudo ln -s /var/lib/dbus/machine-id /etc/machine-id

https://blog.programster.org/fix-ubuntu-18-04-vm-guests-all-getting-the-same-ip?fbclid=IwAR3ptOYnMWW5CFs2RW8asafxXRXEPxxjO1W1iUY8HE2lHdlmYxPiStX95I4

https://jaylacroix.com/fixing-ubuntu-18-04-virtual-machines-that-fight-over-the-same-ip-address/?fbclid=IwAR3bifPhFGxxRgXrxoPyVha-P2zVOYPblCRwXNkbKbzGd634W6zW4M5fuQ8

發表於 未分類 | 發表迴響

mikrotik vpn 封鎖 smb

要封鎖 從 vpn 封鎖 特定主機 smb
smb port 445,137-139

封鎖特定主機
forward dst-address=192.1.68.1.250 prtotcol=6(tcp) Dst-Port=445,137-139 in-inface=pptp-name out-interface=bridge
或
forward dst-address=192.1.68.1.250 prtotcol=6(tcp) Dst-Port=445,137-139
或
封鎖全部 interface
forward prtotcol=6(tcp) Dst-Port=445,137-139 in-inface=pptp-name out-interface=bridge
或
forward prtotcol=6(tcp) Dst-Port=445,137-139 in-inface=pptp-name in-interface=all_ppp

發表於 未分類 | 發表迴響

firefox https

Did the website stop working?

Firefox 43 supports TLS 1.0, 1.1, and 1.2 by default. You shouldn’t need to make any changes, but you can double-check the settings here if you like:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste TLS and pause while the list is filtered

(3) If the security.tls.version.max preference is bolded and "user set" to a value other than 3, right-click > Reset the preference to restore the default value of 3

(4) If the security.tls.version.min preference is bolded and "user set" to a value other than 1, right-click > Reset the preference to restore the default value of 1

The values for these preferences mean:

1 => TLS 1.0
2 => TLS 1.1
3 => TLS 1.2

If you encounter errors on the site, please let us know the specific message you get.

發表於 未分類 | 發表迴響

zfs

一個 120GB 的 L2ARC 將使用大約 5GB 的 RAM 來索引 L2ARC。請記住,L2ARC 是第二級 ARC。你想要 L1ARC(簡稱“ARC” ) 在去 L2ARC 之前盡可能大。考慮到您現在只有 16GB 的 RAM,提供 5GB 的 RAM 來管理 L2ARC 可能會損害您的性能。

可以控制這兩個速度限制的 sysctl(8) 數值分別為 vfs.zfs.l2arc_write_max 控制每秒有多少數位元組可寫入到快取,而 vfs.zfs.l2arc_write_boost 可在 “渦輪預熱階段” (即寫入加速) 時增加寫入限制。

快取 (Cache) – 加入快取 vdev 到儲存池可以增加儲存空間的 L2ARC 快取。快取裝置無法做鏡像,因快取裝置只會儲存額外的現有資料的複本,並沒有資料遺失的風險。

日誌 (Log) – ZFS 記錄裝置,也被稱作 ZFS 意圖日誌 (ZFS Intent Log, ZIL) 會從正常的儲存池裝置移動意圖日誌到獨立的裝置上,通常是一個 SSD。有了獨立的日誌裝置,可以明顯的增進有大量同步寫入應用程式的效能,特別是資料庫。日誌裝置可以做成鏡像,但不支援 RAID-Z,若使用多個日誌裝置,寫入動作會被負載平衡分散到這些裝置。

ZIL 會使用比主要儲存池還更快的儲存裝置來加速同步寫入動作 (Synchronous transaction),如 SSD。當應用程式請求做一個同步的寫入時 (保証資料會安全的儲存到磁碟,而不是先快取稍後再寫入),資料會先寫入到速度較快的 ZIL 儲存空間,之後再一併寫入到一般的磁碟。這可大量的減少延遲並增進效能。ZIL 只會有利於使用像資料庫這類的同步工作,一般非同步的寫入像複製檔案,則完全不會用到 ZIL。

ARC 記憶體 又叫 L1ARC
L2ARC SSD CACHE——大–一個 120GB 的 L2ARC 將使用大約 5GB 的 RAM 來索引 L2ARC
ZIL 基本上zpool中一定有ZIL(ZFS intent log)的存在,ZIL一般是自動分配在zpool的vdev之中,但是在一般使用情況下ZIL只會有連續寫入(等於只是暫存,所以隨機資料一樣排隊當連續寫入),

CLONE 快照也可以做複本,複本是可寫入版本的快照,讓檔案系統可分支成為新的資料集。如同快照,複本一開始不會消耗任何額外空間,隨著新資料寫入到複本會配置新的資料區塊,複本的表面大小 (Apparent size) 才會成長,當在複本檔案系統或磁碟區的資料區塊被覆寫時,在先前資料區塊的參考計數則會減少。建立複本所使用的快照無法被刪除,因為複本會相依該快照,快照為父,複本為子。複本可以被提升 (promoted)、反轉相依關係,來讓複本成為父,之前的父變為子,這個操作不需要額外的空間。由於反轉了父與子使用的空間量,所以可能會影響既有的配額 (Quota) 與保留空間 (Reservation)。

發表於 未分類 | 發表迴響

cmd ftp task kill

常遇到 客戶pcman 當掉乾脆定時每天砍掉重開
@echo off
taskkill /im pcmanftp.exe
c:\ftp\pcmanftp.exe

發表於 未分類 | 發表迴響

windows 常用cmd指令

修改電腦名稱
wmic.exe ComputerSystem Where Name=”%ComputerName%” Rename Name=”NewComputerName”
例:
set /p PCNAME=請輸入電腦編號 :
wmic.exe ComputerSystem Where Name="%ComputerName%" Rename Name=PC%PCNAME%

改網路設備
netsh interface ip set dns “區域連線" static 8.8.8.8
netsh interface ip add dns “區域連線" 168.95.1.1

Disable UAC須重開
C:\Windows\System32\cmd.exe /k %windir%\System32\reg.exe ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 0 /f

Enable UAC須重開
C:\Windows\System32\cmd.exe /k %windir%\System32\reg.exe ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 1 /f

快速获取需要安装的补丁文件
运行 wuauclt.exe /detectnow
或 wuauclt.exe /resetauthorization /detectnow
可以结合 gpresult 和 gpupdate 命令使用。

透過系統管理員開啟控制台
runas /user:administrator control

資源回收桶
explorer.exe ::{645FF040-5081-101B-9F08-00AA002F954E}

我的電腦
explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

網路芳鄰
explorer.exe ::{208D2C60-3AEA-1069-A2D7-08002B30309D}

發表於 未分類 | 發表迴響

Linux自建邮局之本人现在所在公司反垃圾邮件配置+Reject的邮件统计脚本

smtpd_recipient_restrictions =
permit_sasl_authenticated,#检测用户认证是否通过的,认证通过的返回状态OK,否则返回DUNNO状态码。
permit_auth_destination,#不管客户端的主机名,只要符合以下的条件,就接受SMTP连接请求:
#* 解析后的目标地址符合$relay_domains及其子域
#* 解析后的目标地址符合$inet_interfaces、$mydestination或$virtual_maps
permit_mynetworks,#检测客户端是否来自mynetworks或者mynetworks_style的网络,是的话返回OK,否则返回DUNNO状态码。
reject_unauth_destination,#RCPT TO时:收件人不在postfix管辖的区域(由mydestination定义),返回REJECT,否则返回DUNNO状态码。
check_client_access hash:/etc/postfix/rbl_whitelist,#误杀白名单,只要在白名单就允许通过。
reject_unknown_client,#如果客户端的ip地址在DNS中没有PTR记录则拒绝转发该客户端的连接请求。可以用unknown_client_reject_code参数指定返回给客户机的错误代码(缺省为450)。如果你有用户没有作DNS记录则不要启用该选项。
reject_unknown_hostname,#如果客户端执行HELO命令时的主机名在DNS中没有相应的A 或 MX 记录则拒绝该客户端的连接请求。可以用invalid_hostname_reject_code参数指定返回给客户机的错误代码(缺省为450)。
reject_unknown_recipient_domain,#如果收件人的邮件地址在DNS中没有相应的A 或 MX 记录则拒绝该客户端的连接请求。可以用unknown_address_reject_code参数指定返回给客户机的错误代码(缺省为450)。
reject_unknown_sender_domain,#如果MAIL FROM命令提供的主机名在DNS中没有相应的A 或 MX 记录则拒绝该客户端的连接请求。可以用unknown_address_reject_code参数指定返回给客户机的错误代码(缺省为450)。
reject_invalid_hostname,#如果HELO命令所带的主机名参数不符合语法规范则拒绝客户机的连接请求。可以用invalid_hostname_reject_code参数指定返回给客户机的错误代码(缺省为501)。
reject_non_fqdn_hostname,#HELO/EHLO时:客户端提供的主机名不是RFC要求的完整形式(FQND),返回REJECT,否则返回DUNNO状态码。
reject_non_fqdn_recipient,#RCPT TO时:客户端提供的主机名不是RFC要求的完整形式(FQND),返回REJECT,否则返回DUNNO状态码。
reject_non_fqdn_sender,#MAIL FROM时:客户端提供的主机名不是RFC要求的完整形式(FQND),返回REJECT,否则返回DUNNO状态码。
reject_unauth_pipelining,#禁止非授权客户端使用pipelining
reject_unauthenticated_sender_login_mismatch#拒绝认证失败的发送者在
####在线反垃圾SPAM 开始######检测客户端的IP地址或主机名称
reject_rbl_client cblless.anti-spam.org.cn,
reject_rbl_client proxies.relays.monkeys.com,
reject_rbl_client sbl-xbl.spamhaus.org,
reject_rbl_client bl.spamcop.net,
reject_rbl_client cbl.abuseat.org,
reject_rbl_client dul.dnsbl.sorbs.net,
reject_rbl_client relays.ordb.org,
reject_rbl_client dnsbl.njabl.org,
reject_rbl_client relays.osirusoft.com,
reject_rbl_client blackholes.mail-abuse.org,
reject_rbl_client dialups.mail-abuse.org,
reject_rbl_client relays.mail-abuse.org,
reject_rbl_client rbl-plus.mail-abuse.ja.net,
reject_rbl_client blackholes.easynet.nl,
reject_rbl_client proxies.blackholes.easynet.nl,
reject_rbl_client dynablock.easynet.nl,
reject_rbl_client spews.relays.osirusoft.com
####在线反垃圾SPAM 结束######
#=============邮件内容检测================#
body_checks = regexp:/etc/postfix/body_checks
#正文过滤
#=============邮件附件检测================#
header_checks = regexp:/etc/postfix/header_checks
#通过header_checks参数限制接收邮件的信头的格式,如果符合指定的格式,则拒绝接收该邮件。可以指定一个或多个查询列表,如果新邮件的信头符合列表中的某一项则拒绝该接收邮件。
#默认postfix不进行信头过滤。
#=============队列里邮件超时退信设置======#
queue_run_delay = 200s
#用于设定队列处理程序对拖延邮件的扫描周期。缺省为1000秒。
maximal_queue_lifetime = 1
#用于设定队列处理程序对滞留邮件的最长保存期。缺省为5天.
minimal_backoff_time= 200s
#用于设定队列处理程序对无法投递的邮件的最短巡回时间。缺省为1000秒
maximal_backoff_time= 300s
#用于设定队列处理程序对无法投递的邮件的最长巡回时间。缺省为4000秒
bounce_queue_lifetime = 18000s
#退信(弹回)在队列中的保留时间。超过此时间,被认为是无法投递的
maximal_queue_lifetime = 18000s
#普通邮件在队列中的最长保留时间。超过此时间,被认为是无法投递的

#!/bin/bash
#########################################################################
# File Name: /home/script/YesterdayFailMail.sh
# Author: LookBack
# Email: admin#dwhd.org
# Version:
# Created Time: 2015年06月06日 星期六 17时25分30秒
#########################################################################

webhtml="/home/wwwroot/www.dwhd.org/Yesterday_FailMail.html"
grep ‘reject: RCPT’ /var/log/maillog | awk ‘$1=="Jun" && $2==""‘$(date +%d –date "1 days ago")’""{print}’ | \
grep -Eo ‘to=<\b\w+@\w+(-)?.\w+(.\w+)>‘ | sort -u |uniq | sed -r ‘s/to=<|>//g’ | \
awk ‘/这里换成自己公司邮箱的域名/{print "

"$0″

"}’ \
>$webhtml

grep -Eo ‘\b\w+@\w+(-)?.\w+(.\w+)?’ $webhtml | while read line;do
sum=`grep ‘reject: RCPT’ /var/log/maillog | grep "$line" | wc -l`
sed -i "s/$line/&\ \ \ \ 总计拦截:${sum}次/" $webhtml
done

grep ‘reject: RCPT’ /var/log/maillog | awk ‘$1=="Jun" && $2==""‘$(date +%d –date "1 days ago")’""{print}’ >> $webhtml

sed -i ‘/

/!s/ sed -i '/

/!s/>/\>/g’ $webhtml
sed -i ‘/

/!s/$/<\/p>/’ $webhtml
sed -i ‘/

/!s/^/

/’ $webhtml
sed -i ’1i ‘ $webhtml

發表於 未分類 | 發表迴響

shell total ssh

統計命令 (暴力ssh)
find /var/log -name ‘secure*’ -type f | while read line;do awk ‘/Failed/{print $(NF-3)}’ $line;done | awk ‘{a[$0]++}END{for (j in a) if(a[j] > 20) print j"="a[j]}’ | sort -n -t’=’ -k 2

root 隨機24位元密碼
rootpass=`date +%s | sha256sum | base64 | head -c 24` && echo root:$rootpass | chpasswd && echo $rootpass

發表於 未分類 | 發表迴響